CCNP ROUTE 2.0: EIGRP

  • Uses the DUAL algorithm, which determines a loop free network topology
  • When a change occurs only the routing table changes are propagated, NOT the entire routing table.
  • Only routers affected by a topology change update their topology
  • Backup routes means fast convergence – Hybrid, only knows what networks it is connect to, this means faster convergence.
  • Simple configuration doesn’t require multiple areas unlike OSPF.
  • Can summarise from anywhere on the network, unlike OSPF which can only summarise on ABR or ASBR
  • Unequal cost load balancing
  • Rapid convergence

Neighbor Discovery

A EIGRP neighbour relationship is formed between routers by sending a “hello” message to the multicast address 224.0.0.10, if the router is configured (same AS, same subnet etc) and therefore listening an adjacency will be formed.

Five Packet Types

Hello – multicast, used for neighbour discovery to form and maintain adjacency
Updates – are sent initially to exchange the routing table and then when there are routing updates (updates only sent if there is a change, full routing table NOT sent).
Query – routers asks neighbour about a route(s), sent when router goes into Active State.
Reply – router response to a query
Ack – router acknowledges update, query and reply messages

  • Default hello interval is 5 seconds on a high speed link or 60 seconds on a low speed link
  • Default hold time is 3 times the hello interval, therefore 15 seconds a high speed link and 180 seconds on a low speed link

Hello interval can be changed using the command “ip hello-interval eigrp” the hold time can be changed using the command “Ip hold-time eigrp

The command “show ip eigrp neighbors” will display the currently formed adjacencies.


SRTT (Smooth Round Trip Time) – time taken for EIGRP packet to reach neighbour and for an acknowledgement to come back
TO (Retransmission Time Out) – length of time a packet will be retransmitted to neighbour before timeout
Q Cnt (Queue Count) – number of EIGRP packets waiting to be sent
Seq Num (Sequence Number) – sequence number of the last packet received

DUAL Algorithm

DUAL Algorithm calculates the route metrics and queries neighbouring routers. First step it will mark a route as “Active“, which means EIGRP is calculating the route (not currently in the routing table) by sending a “query”. The router will send the query to neighbouring routers requesting information on routes, if it receives a response with a path to the router the route will be added to the routing table and marked as “Passive“, which means DUAL is no longer calculating this route.

EIGRP Tables

Neighbor table

  • Contains the neighbors the routers that have formed and adjacency with and is exchanging routes.
  • Show command “show ip eigrp neighbors

Topology table

  • ALL of the routes learned from neighbours, this includes Successor, Feasible Successor and non-Feasible Successor route
  • Show command “show ip eigrp topology all-links

Routing table

  • Only the BEST route that is actually used to route the traffic. This is determined using the DUAL algorthim.
  • Contains only the “successor” route
  • Show command “show ip route

EIGRP Terminology

Feasible Distance (FD) – is how far the destination network is from the local router. Full metric of the route to the destination network
Advertised Distance (AD) or Reported Distance (RD) – is how far from an upstream neighbour router is to the destination network. Also used to determine a Feasible Successor
Successor – is the route with the lowest feasible distance. This route is installed into the routing table
Feasible Successor – a route with a higher feasible distance to a destination network will become the “feasible successor” but ONLY if the “AD/RD” is less than the FD of the successor.
Active Route
BAD
– searching for a backup route prior to removing from routing table
Passive Route – GOOD – route is in the routing table

EIGRP Metric Calculation

EIGRP metric calculated using Bandwidth, Delay, Reliability, Load and MTU.

  • MTU not really used (sent with route updates, does noting with it)
  • The values must match on the routers attempting to form an adjacency

Bandwidth (K1)
Delay (K3)
Reliability (K4 and K5)
Load (K2)

Metric = K1 * BW + ((K2 * BW) / (256 – load)) + K3 * delay) * (K5/(reliability + K4)
Default metric = 256 *(slowest bw + all link delays)

Set bandwidth on interface

interface serial 0/0
bandwidth 256

Routing Loop Prevention

The Advertised/Reported Distance must be less than the feasible distance, in order to ensure a path is considered loop free. This is a loop prevention mechanism to ensure the next-hop router is closer to the destination next work than the local router.

Load Balancing


EIGRP can load balance traffic over links with equal costs/metrics. In addition it can also distribute traffic over routers that have different metrics; this is called unequal cost load balancing. In order to use Unequal Cost Load Balancing the command “variance” must be used.

Equal Cost Load Balancing

  • 2 or more routes with the same metric will automatically load balance traffic, they are both considered successor routes.
  • As default the maximum paths is 4, can be modified using the command “maximum-paths X” from within EIGRP AS process
  • Maximum paths to load balance over is 16

Un-equal Cost Load Balancing

  • Uses the variance command, multiplying the minimum metric router (successor route) by x to include the feasible successor routes
  • A route that does NOT meet the feasibility condition (AD/RD of route must be less than FD of successor) cannot be used in Unequal Cost Load Balancing, only a feasible successor
  • By default the variance variable is set as 1
  • Variance will need to be set as “3” times the Successor in order to include the Feasible Successors route into the routing table. The “other route” (FD 13, AD 12) cannot/will not be added to the routing table as it does not meet the feasibility condition.

The variance command will include routes with a metric of n times the minimum metric route for the destination. Eg

Unequal Cost Load Balancing Example

Successor:         FD 5, AD 1
Feasible Successor:    FD 12, AD, 4
Other route:        FD 13, AD 12

From the example below you can determine the “Successor” route is via interface Fa0/0 and is installed into the routing table and the “Feasible Successor” route is via interface Fa1/0.



The metric of the “Feasible Successor” route (via Fa1/0) is less than twice the value of the “Successor” route, therefore we need to use the value of 2 with the variance command. This will include all routes no more than twice the value of the successor route in the routing table.

router eigrp 1
variance 2

Notice now using the “show ip eigrp topology all-links” command that there are now 2 successor routes


The routing table now reveals 2 valid routes to the 172.16.0.0/24 network


Notice the traffic share count is different between the 2 paths to the destination. This is because the amount of traffic that can be sent across the path is in proportion to the metric value of the route. This is EIGRPs default, set by the command “traffic-share balanced“.

Another command that can be used is “traffic-share min across-interfaces“. This will use only the minimum cost path or paths (the successor routes), the feasible successor paths will be in the routing table but only used in the event the primary path fails. This allows for faster convergence. As can be seen the screenshot below, both interfaces Fa0/0 and Fa1/0 are in the routing table but Fa0/0 (the path with the lowest metric) is the only path that will send traffic.


Administrative Distance

EIGRP Administrative Distance:    Internal is 90 (D), External is 170 (D EX)

Can change the default AD by using the command “distance eigrp X X” Eg distance eigrp 90 170 under the EIGRP AS process. When the command is implemented this is local significant and is not replicated to other routers.

EIGRP Security

Passive Interface

The passive-interface command will turn off EIGRP Hello messages on the configured interface(s), it will still advertise the networks but it will not send hello messages. Best practice is to disable on all interfaces, then explicitly enable on only the interface(s) that need to establish EIGRP adjacencies.

router eigrp 1
passive-interface default
no passive-interface fastethernet 0/0
no passive-interface serial 0/0

Authentication

When EIGRP authentication is enable every packet will be hashed

You also have the ability to change the keys at regular intervals using the “accept-lifetime” command configured under the key-chain.

key-chain KEY-CHAIN
keys-string cisco12345

You have to enable authentication per interface, with the command “ip authentication mode eigrp <AS NUMBER> md5” Once enter the interface will drop any adjacency. Use the command “ip authentication key-chain eigrp 1 KEY-CHAIN” to enable the key-chain to be used on that interface.

interface fastethernet 0/0
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 KEY-CHAIN

EIGRP Summarization

2 types of EIGRP route summarisation:

Automatic Summarisation

  • Summarises routes when advertised over a classful boundary, could cause issues with overlapping networks over different links
  • Usually disabled “no auto-summary” on IOS 12.x, but disabled as default on 15.x

Manual Summarisation

  • You determine when and where to summarise routes
  • When used the routing table is smaller, making convergence faster, less load on the CPU
  • Routing updates are smaller and less EIGRP queries
  • Less impact of flapping links on the entire network

Summarisation is configured on the interface using the command “ip summary-address eigrp X <NETWORK> <SUBNETMASK>”

interface fastethernet 0/0
ip summary-address eigrp 1 10.10.0.0 255.255.252.0

Route summarisation creates a summarised route, these have an AD of 5, but ONLY on the route that is advertising the route. A null0 route is created on the local router, as a loop prevention mechanism. If a packet enters the local router (the router advertising the summarised route) and the specified route(s) does not exist it will forward the packet to the null0 interface, therefore dropped.

You can confirm the distance of 5 only by using the “show ip route <NETWORK> <SUBNETMASK>” command.


Stub Routes

When used Stub routes reduces the size of the routing tables and the number of EIGRP DUAL queries. Not as complex as OSPF Stub areas.

  • Used when a router is not a transit router and no onward links
  • When upstream router loses a link, it queries neighbour routers – it will not query a router configured as stub
  • A router will also advertised only it’s connected and summary routes to upstream routers as default. You can also advertise “receive-only“, “static” and “redistribute

Configuring a Stub

router eigrp 1
eigrp stub connected summary static redistribute

EIGRP Default Route

  • Inject a static route via route redistribution

    ip route 0.0.0.0 0.0.0.0 192.168.0.1
    router eigrp 1
    redistribute static metric 10000 10 255 1 1500

  • Use the “ip default-network” command to advertise the default network, the router must have the network it its routing table.
  • Default route with the network 0.0.0.0 command

ip route 0.0.0.0 0.0.0.0 192.168.0.1
router eigrp 1
network 0.0.0.0

  • Default route using the “ip summary-address command

ip route 0.0.0.0 0.0.0.0 192.168.0.1
interface fastethernet 0/0
ip summary-address eigrp 1 0.0.0.0 0.0.0.0

EIGRP Named Mode

  • Named Mode allows for all EIGRP related configuration to be contained in the same place (IPv4, IPv6, Timers, Authentication, Summary Addresses etc).
  • Supports SHA2-256 for Authentication
  • Can inter-operate with other devices using Classic Mode EIGRP, assuming the AS is the same

Address Family

address-family ipv4 unicast autonomous-system X” – IPv4 specific configuration
address-family ipv4 vrf VRF1 autonomous-system X” – IPv4 VRF specific configuration
address-family ipv6 unicast autonomous-system X” – IPv6 specific configuration
address-family ipv6 vrf VRF1 unicast autonomous-system X” – IPv6 VRF specific configuration

Once selected whether to configured IPv4/IPv6 with or without VRF the basic configuration is the same.

Specify the networks to enable routing using the “network” command.


Address Family Interface Configuration

Commands previously configured on interfaces are now contained within the “af-interface” configuration, including Timers, Authentication, Passive Interface, Bandwidth Percent etc. This configuration mode can be accessed using the command “af-interface default” which will allow for global configuration of settings or to specific interfaces “af-interface fastethernet 0/0“.

You must exit this configuration mode to access other configuration modes


Address Family Topology Configuration

The Topology configuration mode allows configuration of redistribution, route filtering, variance etc. You enter this mode using the command “topology base” from there you can configure the specific settings

You must exit this configuration mode to access other configuration modes


The screenshot below illustrates the basic configuration of EIGRP Named Mode.


 

 

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s