Configuring RIP between HP ProCurve and Cisco Switches

 

I needed to distribute routes between an HP ProCurve and a Cisco Catalyst switch. The HP ProCurve switch mode used was a 3500-48yl without the premium license; therefore I was only able to use RIP and not OSPF. The Cisco switch used was a Catalyst 3560-8 IOS 12.2(55) IPBase. You will notice from the configuration below the difference in commands between the ProCurve and Cisco switches.


 

ProCurve Switch Configuration

ip routing
vlan 900
name “VLAN900”
untagged 48
ip address 10.0.0.2 255.255.255.0
exit
router rip
no auto-summary
redistribute connected
enable
exit
vlan 900
ip rip 10.0.0.2
exit

 

Cisco Switch Configuration

ip routing
interface GigabitEthernet0/1
no switchport
ip address 10.0.0.1 255.255.255.0
interface loopback 1
ip address 192.168.1.1 255.255.255.0
router rip
version 2
redistribute connected
network 10.0.0.0
no auto-summary

Verification

Running “show ip route” on the ProCurve switch you can see the 192.168.0.0/24 route is learnt via RIP

 


 


 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s